import Foundation
let pattern = #"^(?P<firstname>\b[A-Z][a-z]{1,}\b)\s{1}(?P<lastname>\b[A-Z][a-z]{1,}\b)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Andrew Jones"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${lastname}, ${firstname} "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)