#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\([^)]*)\((.*?)\)"
Local $sString = "Alpha (Bravo( Charlie)) Alpha (Bravo( Charlie)) fasdfsf" & @CRLF & _
"" & @CRLF & _
"Alpha (Bravo Charlie) Alpha (Bravo( Charlie) Hey (Charlie))" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)