re = /(\([^)]*)\((.*?)\)/m
str = 'Alpha (Bravo( Charlie)) Alpha (Bravo( Charlie)) fasdfsf
Alpha (Bravo Charlie) Alpha (Bravo( Charlie) Hey (Charlie))
'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result