import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\([^)]*)\\((.*?)\\)";
final String string = "Alpha (Bravo( Charlie)) Alpha (Bravo( Charlie)) fasdfsf\n\n"
+ "Alpha (Bravo Charlie) Alpha (Bravo( Charlie) Hey (Charlie))\n";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}