package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\([^)]*)\((.*?)\)`)
var str = `Alpha (Bravo( Charlie)) Alpha (Bravo( Charlie)) fasdfsf
Alpha (Bravo Charlie) Alpha (Bravo( Charlie) Hey (Charlie))
`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}