import Foundation
let pattern = #"(\([^)]*)\((.*?)\)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Alpha (Bravo( Charlie)) Alpha (Bravo( Charlie)) fasdfsf
Alpha (Bravo Charlie) Alpha (Bravo( Charlie) Hey (Charlie))
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)