#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?:[\w ]+: ?\$\{[A-Z_]+}(?:\r?\n|$))+$"
Local $sString = "Text description: ${VARIABLE_NAME}" & @CRLF & _
"Text description: ${VARIABLE_NAME}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")