using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:[\w ]+: ?\$\{[A-Z_]+}(?:\r?\n|$))+$";
string input = @"Text description: ${VARIABLE_NAME}
Text description: ${VARIABLE_NAME}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}