const regex = /^(?:[\w ]+: ?\$\{[A-Z_]+}(?:\r?\n|$))+$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[\\w ]+: ?\\$\\{[A-Z_]+}(?:\\r?\\n|$))+$', '')
const str = `Text description: \${VARIABLE_NAME}
Text description: \${VARIABLE_NAME}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}