re = /^(?:[\w ]+: ?\$\{[A-Z_]+}(?:\r?\n|$))+$/
str = 'Text description: ${VARIABLE_NAME}
Text description: ${VARIABLE_NAME}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end