$re = '/^(?:[\w ]+: ?\$\{[A-Z_]+}(?:\r?\n|$))+$/';
$str = 'Text description: ${VARIABLE_NAME}
Text description: ${VARIABLE_NAME}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);