using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^\][]*\]";
string substitution = @"";
string input = @"Keep1[Delete1a
[Delete2]
Delete1b]Keep2a
Keep2b[Delete3]Keep3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}