import re
regex = re.compile(r"\[[^\][]*\]")
test_str = ("Keep1[Delete1a\n"
" [Delete2]\n"
"Delete1b]Keep2a\n"
"Keep2b[Delete3]Keep3")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)