re = /\[[^\][]*\]/
str = 'Keep1[Delete1a
[Delete2]
Delete1b]Keep2a
Keep2b[Delete3]Keep3'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result