import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[[^\\][]*\\]";
final String string = "Keep1[Delete1a\n"
+ " [Delete2]\n"
+ "Delete1b]Keep2a\n"
+ "Keep2b[Delete3]Keep3";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}