#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{9})(?<uniqueSequence>\d{6})(?<dpbc>.{11}))"
Local $sString = "0014120556239013447647712510026" & @CRLF & _
"0014120556239013447747712556417" & @CRLF & _
"0014120556239013447847712504124" & @CRLF & _
"0014120556239013447947712500422" & @CRLF & _
"0014120556239013448047712482006" & @CRLF & _
"0014120556239013448147712494417" & @CRLF & _
"0014120556239013448247712935544"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")