import re
regex = re.compile(r"(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{9})(?<uniqueSequence>\d{6})(?<dpbc>.{11}))", flags=re.MULTILINE)
test_str = ("0014120556239013447647712510026\n"
"0014120556239013447747712556417\n"
"0014120556239013447847712504124\n"
"0014120556239013447947712500422\n"
"0014120556239013448047712482006\n"
"0014120556239013448147712494417\n"
"0014120556239013448247712935544")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")