use strict;
my $str = '0014120556239013447647712510026
0014120556239013447747712556417
0014120556239013447847712504124
0014120556239013447947712500422
0014120556239013448047712482006
0014120556239013448147712494417
0014120556239013448247712935544';
my $regex = qr/(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{9})(?<uniqueSequence>\d{6})(?<dpbc>.{11}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}