import Foundation
let pattern = #"(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{9})(?<uniqueSequence>\d{6})(?<dpbc>.{11}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0014120556239013447647712510026
0014120556239013447747712556417
0014120556239013447847712504124
0014120556239013447947712500422
0014120556239013448047712482006
0014120556239013448147712494417
0014120556239013448247712935544
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)