const regex = /(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{9})(?<uniqueSequence>\d{6})(?<dpbc>.{11}))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(?<barCodeId>\\d{2})(?<serviceType>\\d{3})(?<mailerId>\\d{9})(?<uniqueSequence>\\d{6})(?<dpbc>.{11}))', 'gm')
const str = `0014120556239013447647712510026
0014120556239013447747712556417
0014120556239013447847712504124
0014120556239013447947712500422
0014120556239013448047712482006
0014120556239013448147712494417
0014120556239013448247712935544`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}