#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([1-2][0-9])|(3[0-1])|(0?[1-9]))\/((0?[1-9])|(1[0-2]))\/(\d{4})$"
Local $sString = "08/04/2022" & @CRLF & _
"8/4/2022" & @CRLF & _
"30/4/2021" & @CRLF & _
"33/5/2022" & @CRLF & _
"2/13/2030"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")