import re
regex = re.compile(r"^(([1-2][0-9])|(3[0-1])|(0?[1-9]))\/((0?[1-9])|(1[0-2]))\/(\d{4})$", flags=re.MULTILINE)
test_str = ("08/04/2022\n"
"8/4/2022\n"
"30/4/2021\n"
"33/5/2022\n"
"2/13/2030")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")