package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(([1-2][0-9])|(3[0-1])|(0?[1-9]))\/((0?[1-9])|(1[0-2]))\/(\d{4})$`)
var str = `08/04/2022
8/4/2022
30/4/2021
33/5/2022
2/13/2030`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}