import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([1-2][0-9])|(3[0-1])|(0?[1-9]))\\/((0?[1-9])|(1[0-2]))\\/(\\d{4})$";
final String string = "08/04/2022\n"
+ "8/4/2022\n"
+ "30/4/2021\n"
+ "33/5/2022\n"
+ "2/13/2030";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}