re = /^(([1-2][0-9])|(3[0-1])|(0?[1-9]))\/((0?[1-9])|(1[0-2]))\/(\d{4})$/m
str = '08/04/2022
8/4/2022
30/4/2021
33/5/2022
2/13/2030'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end