import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/[!-~]+?&query=(?=.*[^!-~]).+$";
final String string = "https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=나.\n"
+ "https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=Tôi\n"
+ "https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=测试\n"
+ "https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}