$re = '/^https?:\/\/[!-~]+?&query=(?=.*[^!-~]).+$/m';
$str = 'https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=나.
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=Tôi
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=测试
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);