const regex = /^https?:\/\/[!-~]+?&query=(?=.*[^!-~]).+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/[!-~]+?&query=(?=.*[^!-~]).+$', 'gm')
const str = `https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=나.
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=Tôi
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=测试
https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}