import re
regex = re.compile(r"^https?:\/\/[!-~]+?&query=(?=.*[^!-~]).+$", flags=re.MULTILINE)
test_str = ("https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=나.\n"
"https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=Tôi\n"
"https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=测试\n"
"https://weixin.sogou.com/weixin?type=2&ie=utf-8&s_from=hotnews&query=test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")