#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<Data Name='NewProcessName'>(C:\\Windows\\Sysatem32\\inetsrv\\w3wp.exe)|(C:\\Program\\VMware\\VMware Tools\\vmtoolsd.exe)|(C:\\Windows\\System32\\wbem\\WmiPrvSE.exe)</Data>"
Local $sString = "<Data Name='NewProcessName'>(C:\\Windows\\Sysatem32\\inetsrv\\w3wp.exe)|(C:\\Program\\VMware\\VMware Tools\\vmtoolsd.exe)|(C:\\Windows\\System32\\wbem\\WmiPrvSE.exe)</Data>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")