const regex = /<Data Name='NewProcessName'>(C:\\Windows\\Sysatem32\\inetsrv\\w3wp.exe)|(C:\\Program\\VMware\\VMware Tools\\vmtoolsd.exe)|(C:\\Windows\\System32\\wbem\\WmiPrvSE.exe)</Data>/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<Data Name=\'NewProcessName\'>(C:\\\\Windows\\\\Sysatem32\\\\inetsrv\\\\w3wp.exe)|(C:\\\\Program\\\\VMware\\\\VMware Tools\\\\vmtoolsd.exe)|(C:\\\\Windows\\\\System32\\\\wbem\\\\WmiPrvSE.exe)<\/Data>', '')
const str = `<Data Name='NewProcessName'>(C:\\\\Windows\\\\Sysatem32\\\\inetsrv\\\\w3wp.exe)|(C:\\\\Program\\\\VMware\\\\VMware Tools\\\\vmtoolsd.exe)|(C:\\\\Windows\\\\System32\\\\wbem\\\\WmiPrvSE.exe)</Data>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}