// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<Data Name='NewProcessName'>(C:\\Windows\\Sysatem32\\inetsrv\\w3wp.exe)|(C:\\Program\\VMware\\VMware Tools\\vmtoolsd.exe)|(C:\\Windows\\System32\\wbem\\WmiPrvSE.exe)</Data>").unwrap();
let string = "<Data Name='NewProcessName'>(C:\\\\Windows\\\\Sysatem32\\\\inetsrv\\\\w3wp.exe)|(C:\\\\Program\\\\VMware\\\\VMware Tools\\\\vmtoolsd.exe)|(C:\\\\Windows\\\\System32\\\\wbem\\\\WmiPrvSE.exe)</Data>
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}