$re = '/<Data Name=\'NewProcessName\'>(C:\\\\Windows\\\\Sysatem32\\\\inetsrv\\\\w3wp.exe)|(C:\\\\Program\\\\VMware\\\\VMware Tools\\\\vmtoolsd.exe)|(C:\\\\Windows\\\\System32\\\\wbem\\\\WmiPrvSE.exe)</Data>/';
$str = '<Data Name=\'NewProcessName\'>(C:\\\\Windows\\\\Sysatem32\\\\inetsrv\\\\w3wp.exe)|(C:\\\\Program\\\\VMware\\\\VMware Tools\\\\vmtoolsd.exe)|(C:\\\\Windows\\\\System32\\\\wbem\\\\WmiPrvSE.exe)</Data>
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);