import re
regex = re.compile(r"<Data Name='NewProcessName'>(C:\\Windows\\Sysatem32\\inetsrv\\w3wp.exe)|(C:\\Program\\VMware\\VMware Tools\\vmtoolsd.exe)|(C:\\Windows\\System32\\wbem\\WmiPrvSE.exe)</Data>")
test_str = ("<Data Name='NewProcessName'>(C:\\\\Windows\\\\Sysatem32\\\\inetsrv\\\\w3wp.exe)|(C:\\\\Program\\\\VMware\\\\VMware Tools\\\\vmtoolsd.exe)|(C:\\\\Windows\\\\System32\\\\wbem\\\\WmiPrvSE.exe)</Data>\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")