import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<Data Name='NewProcessName'>(C:\\\\Windows\\\\Sysatem32\\\\inetsrv\\\\w3wp.exe)|(C:\\\\Program\\\\VMware\\\\VMware Tools\\\\vmtoolsd.exe)|(C:\\\\Windows\\\\System32\\\\wbem\\\\WmiPrvSE.exe)</Data>";
final String string = "<Data Name='NewProcessName'>(C:\\\\Windows\\\\Sysatem32\\\\inetsrv\\\\w3wp.exe)|(C:\\\\Program\\\\VMware\\\\VMware Tools\\\\vmtoolsd.exe)|(C:\\\\Windows\\\\System32\\\\wbem\\\\WmiPrvSE.exe)</Data>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}