#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,4}[A-Z\d]?$"
Local $sString = "1A" & @CRLF & _
"11A" & @CRLF & _
"111A" & @CRLF & _
"1111A" & @CRLF & _
"1" & @CRLF & _
"11" & @CRLF & _
"111" & @CRLF & _
"1111" & @CRLF & _
"11111" & @CRLF & _
"" & @CRLF & _
"1A11" & @CRLF & _
"2A2" & @CRLF & _
"222A1" & @CRLF & _
"A11" & @CRLF & _
"AA" & @CRLF & _
"AA1" & @CRLF & _
"A1A" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")