import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{1,4}[A-Z\\d]?$";
final String string = "1A\n"
+ "11A\n"
+ "111A\n"
+ "1111A\n"
+ "1\n"
+ "11\n"
+ "111\n"
+ "1111\n"
+ "11111\n\n"
+ "1A11\n"
+ "2A2\n"
+ "222A1\n"
+ "A11\n"
+ "AA\n"
+ "AA1\n"
+ "A1A\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}