re = /^\d{1,4}[A-Z\d]?$/m
str = '1A
11A
111A
1111A
1
11
111
1111
11111
1A11
2A2
222A1
A11
AA
AA1
A1A
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end