use strict;
my $str = '1A
11A
111A
1111A
1
11
111
1111
11111
1A11
2A2
222A1
A11
AA
AA1
A1A
';
my $regex = qr/^\d{1,4}[A-Z\d]?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}