package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,4}[A-Z\d]?$`)
var str = `1A
11A
111A
1111A
1
11
111
1111
11111
1A11
2A2
222A1
A11
AA
AA1
A1A
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}