const regex = /^\d{1,4}[A-Z\d]?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,4}[A-Z\\d]?$', 'gm')
const str = `1A
11A
111A
1111A
1
11
111
1111
11111
1A11
2A2
222A1
A11
AA
AA1
A1A
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}