use strict;
my $str = '1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101';
my $regex = qr/(?<!\S)(?!(?:January|February|March|April|May|June|July|August|September|October|November|December|\d+)(?:\s|$))\S+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";