re = /(?<!\S)(?!(?:January|February|March|April|May|June|July|August|September|October|November|December|\d+)(?:\s|$))\S+/
str = '1 circa February 1950
testing July August Septiembre Octubre 7 8 9 10 10b ... 101'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result