using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\'\""\`])(.*)\1";
string input = @"'string in simple quotes'
""in double-quotes""
`in back-quotes`
""Works good with symbols ' or "" or ` inside the string""
""All quotes ""'` inside string are ignored""
""Matches only identical quotes on string start and end' // regex can`t find this
""
Single-line flag allows regex to finde multiline
strings like this
"" // but now flag s turned of
""Group 2 saves text inside quotes""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}