re = /([\'\"\`])(.*)\1/m
str = '\'string in simple quotes\'
"in double-quotes"
`in back-quotes`
"Works good with symbols \' or " or ` inside the string"
"All quotes "\'` inside string are ignored"
"Matches only identical quotes on string start and end\' // regex can`t find this
"
Single-line flag allows regex to finde multiline
strings like this
" // but now flag s turned of
"Group 2 saves text inside quotes"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end