import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\'\\\"\\`])(.*)\\1";
final String string = "'string in simple quotes'\n"
+ "\"in double-quotes\"\n"
+ "`in back-quotes`\n"
+ "\"Works good with symbols ' or \" or ` inside the string\"\n"
+ "\"All quotes \"'` inside string are ignored\"\n"
+ "\"Matches only identical quotes on string start and end' // regex can`t find this\n\n"
+ "\"\n"
+ "Single-line flag allows regex to finde multiline\n"
+ "strings like this\n"
+ "\" // but now flag s turned of\n\n"
+ "\"Group 2 saves text inside quotes\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}