use strict;
my $str = '\'string in simple quotes\'
"in double-quotes"
`in back-quotes`
"Works good with symbols \' or " or ` inside the string"
"All quotes "\'` inside string are ignored"
"Matches only identical quotes on string start and end\' // regex can`t find this
"
Single-line flag allows regex to finde multiline
strings like this
" // but now flag s turned of
"Group 2 saves text inside quotes"';
my $regex = qr/([\'\"\`])(.*)\1/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}