import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]{2,4})(_)(\\d{2})_(0*)(\\d+)(_.+)?";
final String string = "BTS_33_198_D\n"
+ "PL_14_015\n";
final String subst = "\\1\\\\\\2\\3\\\\_%\\5%";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}