// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"(?m)^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?").unwrap();
  let string = "BTS_33_198_D
PL_14_015
";
  let substitution = "\\1\\\\\\2\\3\\\\_%\\5%";
  
  // result will be a String with the substituted value
  let result = regex.replace_all(string, substitution);
  
  println!("{}", result);
}