import re
regex = re.compile(r"^([a-zA-Z]{2,4})(_)(\d{2})_(0*)(\d+)(_.+)?", flags=re.MULTILINE)
test_str = ("BTS_33_198_D\n"
"PL_14_015\n")
subst = "\\1\\\\\\2\\3\\\\_%\\5%"
result = regex.sub(subst, test_str)
if result:
print(result)